mijn-design

a developer\’s life

Archive for January, 2008

Arc released

Posted by Michael on January 30, 2008

On Hacker News I red it: Arc is out !

Posted in Development, Linux, LISP, OS X | Leave a Comment »

Virus, Trojan & Co: Smitfraud.c-Core Service

Posted by Michael on January 30, 2008

A friend’s old Win2k machine was really crowed with virusses and trojans. His son didn’t care about anything surfing hacker websites etc. 🙂

Repaired the installation but couldn’t get connected to updates or any website. Luckily I had SP4 on a CD and with the help of free antivir programs most things worked, but there were still strange processes on the system. Hijackthis and Spybot helped really alot here.

But one resisted: Smitfraud.c-Core Service

Google showed that many users had / have big problems with this. I was lucky and found a solution in a german forum : here (scroll down a bit)
After downloading SDfix.zip, restarted in safe mode, and ran the batch file. Got an error about not beeing able to add entries from an reg file to the registry but after rebooting and watching the ongoing cleaning process in a command window, finally it was gone !!

Posted in MS Windows 2000 | 1 Comment »

VMware Fusion “The network bridge device on /dev/vmnet0 is not running”

Posted by Michael on January 27, 2008

Suddenly ran into this problem, no vm worked anymore. Searching the internet gave me hints but no solution.

The clue was in the System profiler. I had switched from a server based to a local pppoe connection. This pppoe connection showed in system profiler as another ethernet en0 BSD device name. After deleting and re-creating the pppoe connection on the second internal ethernet en1 everything was ok again !

Nothing perfect yet …
Switching to local pppoe I have to remove the router entry from the network device, but then vm’s don’t work anymore.
But with an router entry internet doesn’t work correct.

I use now wo different network configurations in Leopard: one server based with a router entry and another one with a local pppoe connection.

Edit /23.02.2008: Another failure, this entry helped
Edit /20.04.2008: Every now and then I still get this error. Either this command

    sudo /Library/Application Support/VMWare Fusion/boot.sh –restart
or rebooting helps.

Posted in Mac, OS X, VMware Fusion | 52 Comments »

Time passes by …

Posted by Michael on January 23, 2008

1.5 year since my last post, had a really hard time, lots of trouble with customers and projects plus some private.
So no time for any progress in lisp development, forgot most about I think, so better re-start from the basics.

A major change is my move from M$ Windows to Apple Macintosh / Mac OS X as my standard working enviroment. At the moment running Leopard on a normal PC (bought a family pack and lots of other software already) I’m looking forward to buying a 24″ iMac plus a Mac Pro this spring and maybe later a MacBook Pro, the MacBook Air is nice but yet neither afforable nor powerfull enough. In the meantime have to learn a lot about development with XCode / Objective-C / Cocoa, really fascinating ! Reminds me of the NeXT Cube 🙂

Concerning Lisp: Lispbox is coming with OpenMCL 1.0, ReadyLisp with AquaMacs and SBCL, if you work with Eclipse maybe Dandelion is of interest for you. And there is a version of newLisp for OS X ( I know newLisp is not CL, but it is interesting ).

Posted in Mac, OS X, Private | Leave a Comment »